昨天按照同事给的文档安装了下libreoffice,今天发现yum安装的时候出现Error: xz compression not available。在网上查看了下资料,可以去这里看一下。

发现是我在centos6下更换了centos7的yum源,解决办法:


rm -rf /etc/yum.repos.d/epel*  

看网上说,安装软件时错误安装了centos7版本的软件,软件不兼容也会导致yum不可用。
这个可以查看/root/install.log安装日志,找到不兼容软件,卸载即可(这种方式没测试~)。